<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://readwrite.com/xmlrpc.php">
<!--[if lt IE 9]>
	<script src="https://readwrite.com/wp-content/themes/rw/js/html5.js"></script>
	<![endif]-->
<title>How APIs and Machine Learning are Evolving - ReadWrite</title>
<script type="text/javascript">
		var ajaxurl = 'https://readwrite.com/wp-admin/admin-ajax.php';
		</script>

<meta name="description" content="API&#039;s and Machine Learning are intertwined in ways in which we can hardly conceive at present. As we interact with each other we&#039;ll make both better." />
<link rel="canonical" href="https://readwrite.com/2019/03/21/how-apis-and-machine-learning-are-evolving/" />
<link rel="publisher" href="https://plus.google.com/+ReadWriteWeb" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How APIs and Machine Learning are Evolving - ReadWrite" />
<meta property="og:description" content="API&#039;s and Machine Learning are intertwined in ways in which we can hardly conceive at present. As we interact with each other we&#039;ll make both better." />
<meta property="og:url" content="https://readwrite.com/2019/03/21/how-apis-and-machine-learning-are-evolving/" />
<meta property="og:site_name" content="ReadWrite" />
<meta property="article:publisher" content="https://www.facebook.com/ReadWrite" />
<meta property="article:tag" content="AI Machine Learning" />
<meta property="article:tag" content="APIs" />
<meta property="article:tag" content="auto-home" />
<meta property="article:tag" content="Connected Devices" />
<meta property="article:tag" content="IoT" />
<meta property="article:section" content="API" />
<meta property="article:published_time" content="2019-03-21T15:00:20+00:00" />
<meta property="article:modified_time" content="2019-03-13T01:03:52+00:00" />
<meta property="og:updated_time" content="2019-03-13T01:03:52+00:00" />
<meta property="og:image" content="https://images.readwrite.com/wp-content/uploads/2019/03/How-APIs-and-Machine-Learning-are-Evolving-900x600.jpg" />
<meta property="og:image:secure_url" content="https://images.readwrite.com/wp-content/uploads/2019/03/How-APIs-and-Machine-Learning-are-Evolving-900x600.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="600" />
<meta property="og:image:alt" content="machine learning is evolving" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="API&#039;s and Machine Learning are intertwined in ways in which we can hardly conceive at present. As we interact with each other we&#039;ll make both better." />
<meta name="twitter:title" content="How APIs and Machine Learning are Evolving - ReadWrite" />
<meta name="twitter:site" content="@RWW" />
<meta name="twitter:image" content="https://images.readwrite.com/wp-content/uploads/2019/03/How-APIs-and-Machine-Learning-are-Evolving.jpg" />
<meta name="twitter:creator" content="@RWW" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://readwrite.com/","sameAs":["https://www.facebook.com/ReadWrite","https://www.linkedin.com/company/readwrite","https://plus.google.com/+ReadWriteWeb","https://www.youtube.com/user/readwriteTV","https://twitter.com/RWW"],"@id":"https://readwrite.com/#organization","name":"ReadWrite","logo":"https://readwrite.com/wp-content/uploads/2016/03/logo.png"}</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ReadWrite &raquo; Feed" href="https://readwrite.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ReadWrite &raquo; Comments Feed" href="https://readwrite.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/readwrite.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://readwrite.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='unslider-css-css' href='https://readwrite.com/wp-content/uploads/706/881/public/assets/css/348.css' type='text/css' media='all' />
<link rel='stylesheet' id='slider-css-css' href='https://readwrite.com/wp-content/uploads/706/881/public/assets/css/914.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://readwrite.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='wptheme-style-css' href='https://readwrite.com/wp-content/themes/rw/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wppb_stylesheet-css' href='https://readwrite.com/wp-content/plugins/profile-builder-pro/assets/css/style-front-end.css' type='text/css' media='all' />
<script type='text/javascript' src='https://readwrite.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/881/public/assets/js/823.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/881/public/assets/js/428.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/881/public/assets/js/227.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/140/public/assets/js/advanced.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/522/public/assets/js/165.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/693/54/39/assets/js/800.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/themes/rw/scripts/jquery.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/themes/rw/scripts/jquery-migrate.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/themes/rw/scripts/social-scroll.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/readwrite.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"1","lazy_load":{"default_offset":0,"offsets":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/693/54/666/451/648.js'></script>
<link rel='https://api.w.org/' href='https://readwrite.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://readwrite.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://readwrite.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.1.1" />
<link rel='shortlink' href='https://readwrite.com/?p=150315' />
<link rel="alternate" type="application/json+oembed" href="https://readwrite.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://readwrite.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F&#038;format=xml" />
<script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="advads-layer-custom-css"></style><script type="text/javascript">
		;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = '';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script><link rel="amphtml" href="https://readwrite.com/2019/03/21/how-apis-and-machine-learning-are-evolving/amp/"><link rel="icon" href="https://images.readwrite.com/wp-content/uploads/2018/03/cropped-rw-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://images.readwrite.com/wp-content/uploads/2018/03/cropped-rw-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://images.readwrite.com/wp-content/uploads/2018/03/cropped-rw-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://images.readwrite.com/wp-content/uploads/2018/03/cropped-rw-270x270.jpg" />
<style type="text/css" id="wp-custom-css">
			.single .entry-content li {display:list-item;}

.annual-salary{padding:1em 0 0;margin:1em 0 0;float:left; width:100%;}
.annual-salary h5{text-align:center;display: block;margin-bottom:2em;}
.annual-salary h2{color:#ca3838;font-size: 4.5em;font-weight: 700;}
.annual-salary p{margin-bottom: 1em;color:#545353;font-size: 1.1em;}

.site-reach{padding:1em 0 0;margin:1em 0 0;float:left; width:100%;}
.site-reach .inner{padding:1em;position: absolute;top:0;left:1em;}
.site-reach h5{font-size: 2em;font-weight: 600;color:#fff;}
.site-reach p{text-transform: uppercase;font-weight: 600;color:#fff;line-height: 1.25em;}
.site-reach .row{margin-bottom: 1em;}
.site-reach .row:last-child{margin-bottom:0;}
.site-reach .total-reach h5{text-transform: uppercase;color:#222529;}
.site-reach .total-reach p{color:#222529;font-weight: 1.25em;}
.site-reach img{max-width: 100%;height:auto !important}
.site-reach h2{color:#ca3838;font-weight: 700;font-size: 5em;}
.media-platform {padding:1em 0 0;margin:1em 0 0em;float:left; width:100%;}
.media-platform .col-md-5 h5{color:#ca3838;font-weight: 600;font-size: 2em;margin-bottom: 0;}
.media-platform .col-md-5 p{color:#545353;font-size: 1.1em;font-weight: 600;margin-bottom: 1em !important}
.page article .entry-content img{height:auto;}
.advertise-form{margin-top:2em}
.advertise-form .col-md-6{margin:0px;}
.advertise-form .col-md-6 input{padding:0.25em;margin:0.5em 0;border:1px solid #f1f1f1;color:#545353;max-width: 100%;}
.advertise-form .col-md-6 select{padding:0.25em;margin:0.5em 0;display: block;border:1px solid #f1f1f1;width:100%;color:#545353}
.advertise-form textarea{width:100%;padding:0.25em;margin:0.5em 0;border:1px solid #f1f1f1;color:#545353}
.advertise-form input[type="submit"]{margin: 1em auto;display: block;border: 0;background: #ca3838;padding: 0.5em 2em;color: #fff;cursor:pointer;}
.content-seperator{margin: 1em 0;padding: 1em 0;border-bottom: 1px solid #f2f2f2;float: left;width: 100%;}
.popular-tags .post_tags li{display:inline;font-size: 0.9em;
line-height: 2.25em;}
.error404 .search-form{text-align:center;}

@media only screen 
and (min-device-width : 768px) 
and (max-device-width : 1024px)  { 
	.media-platform .col-md-5{margin-top:1.5em;}
.trending-post-desc .entry-title a{font-size: 0.9em !important}
.trending-post-desc .entry-content{display: none;}
.most-rending img{min-height: 283px !important}
.entry-meta .author a{line-height: 1.5em;}
#menu-social-media li{display:inline-block;}
.trending-posts-row .trending-post-desc{padding-left: 1em !important;max-width: 70% !important;flex:0 0 70.707070%}
.home-posts-wrap .posts-inner .entry-content{display: none}
.cat-most-popular .most-popular-post-desc .entry-content{display: none}
.cat-loop .posts-inner .most-popular-posts-desc .entry-content{display: none}
.tag .posts-inner .entry-content{display: none}
.author .posts-inner .entry-content{display: none}
}
.sidenav ul{margin:0 0 0.75em}
.sidenav li{line-height:1.25em;}
.sidenav li a{font-size:1em;}
#mySidenav h4{font-size:1em}
#mySidenav .site-branding img{margin-bottom:1.5em;}
.single .entry-content ol{}
.single .entry-content ol h2{font-size:1em;}
.single .about-author .author-description .author-title a{color:#393a3b}		</style>
</head>
<body class="post-template-default single single-post postid-150315 single-format-standard wp-custom-logo">
<div id="mySidenav" class="sidenav col-md-2">
<div id="mySidenav-inner">
<div class="site-branding">
<a href="https://readwrite.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="148" height="26" src="https://images.readwrite.com/wp-content/uploads/2018/05/logo.png" class="custom-logo" alt="ReadWrite" itemprop="logo" /></a> </div>
<a href="javascript:void(0)" class="closebtn">&times;</a>
<div class="clearfix"></div>
<div class="row">
<div class="col-md-12">
<h4>Grow</h4>
<ul>
<li><a href="https://readwrite.com/category/sales/">Sales</a></li>
<li><a href="https://readwrite.com/category/marketing/">Marketing</a></li>
<li><a href="https://readwrite.com/category/customer-service/">Customer Service</a></li>
<li><a href="https://readwrite.com/category/iot/">IoT</a></li>
<li><a href="https://readwrite.com/category/arvr/">AR/VR</a></li>
<li><a href="https://readwrite.com/category/code/">Code</a></li>
<li><a href="https://readwrite.com/category/data-and-security/">Data and Security</a></li>
<li><a href="https://readwrite.com/category/energy/">Energy</a></li>
<li><a href="https://readwrite.com/category/hack/">Hack</a></li>
<li><a href="https://readwrite.com/category/web/">Web</a></li>
<ul>
</div>
<div class="col-md-12">
<h4>Lead</h4>
<ul>
<li><a href="https://readwrite.com/category/productivity/">Productivity</a></li>
<li><a href="https://readwrite.com/category/culture/">Culture</a></li>
<li><a href="https://readwrite.com/category/branding/">Branding</a></li>
<li><a href="https://readwrite.com/category/tech/">Tech</a></li>
<li><a href="https://readwrite.com/category/cloud/">Cloud</a></li>
<li><a href="https://readwrite.com/category/connect/">Connect</a></li>
<li><a href="https://readwrite.com/category/deals/">Deals</a></li>
<li><a href="https://readwrite.com/category/fund/">Fund</a></li>
<li><a href="https://readwrite.com/category/health/">Health</a></li>
<li><a href="https://readwrite.com/category/startups/">Startups</a></li>
<ul>
</div>
<div class="col-md-12">
<h4>Site Links</h4>
<ul>
<li><a href="/about/">About</a></li>
<li><a href="/advertise/">Advertise</a></li>
<li><a href="/events/">Events</a></li>
<li><a href="/contributor-guidelines/">Guest Post</a></li>
<li><a href="/contact/">Contact</a></li>
<li><a href="/privacy/">Privacy</a></li>
<ul>
</div>
</div>
</div>
</div>
<div id="page" class="hfeed container-fluid">
<div class="row">
<div id="sidebar" class="sidebar col-md-2">
<div id="leftsidebar" class="col-md-2">
<header id="masthead" class="site-header" role="banner">
<div class="site-branding">
<a href="https://readwrite.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="148" height="26" src="https://images.readwrite.com/wp-content/uploads/2018/05/logo.png" class="custom-logo" alt="ReadWrite" itemprop="logo" /></a> </div>

<div class="navbar-header">
<div class="mobile-search">
<span class="search-icon">&nbsp;</span>
<div id="widget-area" class="widget-area" role="complementary">
<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://readwrite.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></aside> <a href="javascript:void(0)" class="closesearch" onclick="closeNav()">&times;</a>
</div>
</div>
<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-ex1-collapse">
<span class="icon-bar"><img src="https://readwrite.com/wp-content/themes/rw/images/mobile-menu.png" alt="Mobile menu" /></span>
</button>
</div>
</header>
<div id="secondary" class="secondary">
<nav id="site-navigation" class="main-navigation navigation" role="navigation">
<div class="collapse navbar-collapse navbar-ex1-collapse">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="nav navbar-nav"><li id="menu-item-125069" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-125069"><a href="https://readwrite.com/category/ai/">AI</a></li>
<li id="menu-item-125070" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-125070"><a href="https://readwrite.com/category/blockchain/">Blockchain</a></li>
<li id="menu-item-134432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134432"><a href="https://readwrite.com/category/connected-devices/">Connected Devices</a></li>
<li id="menu-item-125071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-125071"><a href="https://readwrite.com/category/fintech/">Fintech</a></li>
<li id="menu-item-134448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134448"><a href="https://readwrite.com/category/industrial/">Industrial</a></li>
<li id="menu-item-143441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143441"><a href="https://readwrite.com/category/startups/">Startups</a></li>
<li id="menu-item-134447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134447"><a href="https://readwrite.com/category/smart-cities/">Smart Cities</a></li>
<li id="menu-item-134446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134446"><a href="https://readwrite.com/category/transport/">Transport</a></li>
<li id="menu-item-125076" class="menu-popup menu-item menu-item-type-custom menu-item-object-custom menu-item-125076"><a href="#">More</a></li>
</ul></div> </div>
</nav>
<div id="widget-area" class="widget-area" role="complementary">
<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://readwrite.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></aside> </div>
<nav id="social-navigation" class="social-navigation" role="navigation">
<div class="menu-social-media-container"><ul id="menu-social-media" class="menu"><li id="menu-item-125046" class="fb menu-item menu-item-type-custom menu-item-object-custom menu-item-125046"><a target="_blank" href="https://www.facebook.com/ReadWrite"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-125047" class="twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-125047"><a target="_blank" href="https://twitter.com/RWW"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-125048" class="insta menu-item menu-item-type-custom menu-item-object-custom menu-item-125048"><a target="_blank" href="https://www.instagram.com/readwritedotcom/"><span class="screen-reader-text">Instagram</span></a></li>
<li id="menu-item-125050" class="gplus menu-item menu-item-type-custom menu-item-object-custom menu-item-125050"><a target="_blank" href="https://plus.google.com/+ReadWriteWeb/posts"><span class="screen-reader-text">Gplus</span></a></li>
<li id="menu-item-125051" class="ytube menu-item menu-item-type-custom menu-item-object-custom menu-item-125051"><a target="_blank" href="https://www.youtube.com/channel/UClMPvTStrcn829w34OWNEPw"><span class="screen-reader-text">Youtube</span></a></li>
</ul></div> </nav>
</div>
</div>
</div>
<div id="content" class="site-content col-md-10">
<div class="header-ad-wrap">
<div id="rwads-12ceb54b5c42fbf516cc5e3fe5d911c0"></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<article id="post-150315" class="post-150315 post type-post status-publish format-standard has-post-thumbnail hentry category-ai category-api tag-ai-machine-learning tag-apis tag-auto-home tag-connected-devices tag-iot">
<div class="row posts-inner">
<div class="clearfix"></div>
<div class="single-featured-img col-md-12">
<div class="single-post-desc col-md-12">
<header class="entry-header">
<h1 class="entry-title">How APIs and Machine Learning are Evolving</h1> </header>
<div class="clearfix"></div>
<div class="entry-meta col-md-12">
<span class="author">
<a href="https://readwrite.com/author/anant-jhingran/">Anant Jhingran</a>
</span>
<span class="seperator">/</span>
<span class="post-cat">21 Mar 2019</span>
<span class="seperator">/</span>
<span class="author catname"><a href="https://readwrite.com/category/ai/" rel="category tag">AI</a> / <a href="https://readwrite.com/category/api/" rel="category tag">API</a></span>
</div>
</div>
<div class="post-thumb col-md-11 offset-1">
<img width="825" height="500" src="https://images.readwrite.com/wp-content/uploads/2019/03/How-APIs-and-Machine-Learning-are-Evolving-825x500.jpg" class="attachment-single-featured size-single-featured wp-post-image" alt="machine learning is evolving" /> </div>
</div>
<div class="clearfix"></div>
<div class="row">
<div class="col-md-1 post-author-profile">
<div class="menu-social-media-container" id="single">
<div id="scroller-anchor"></div>
<ul id="menu-social-media" class="menu">
<li> <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F" target="_blank" title="Facebook"><img src="https://readwrite.com/wp-content/themes/rw/images/fb-icon-light.png" /></a></li>
<li><a href="https://twitter.com/intent/tweet?text=How%20APIs%20and%20Machine%20Learning%20are%20Evolving&amp;url=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F&amp;via=RWW" title="Twitter" target="_blank"><img src="https://readwrite.com/wp-content/themes/rw/images/twitter-icon-light.png" /></a></li>
<li><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F" title="Linkedin" target="_blank"><img src="https://readwrite.com/wp-content/themes/rw/images/linkedin.png" /></a></li>
<li><a href="mailto:?Subject=Post From Read Write&Body=I%20saw%20this%20and%20thought%20of%20you!%20https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F&text=How%20APIs%20and%20Machine%20Learning%20are%20Evolving" title="Email" target="_blank"><img src="https://readwrite.com/wp-content/themes/rw/images/email-share-icon.png" /></a></li>
</ul>
</div>
</div>
<div class="entry-content col-md-10">
<p><span style="font-weight: 400;">Application programming interfaces (APIs) are the mechanisms that connect data, services, and apps to create modern digital experiences. If a <a href="https://readwrite.com/2019/03/07/heres-why-ai-is-the-solution-to-ecommerce-businesss-biggest-woes/">consumer browses</a> through some products on a retailer’s app, API calls are what seamlessly pull together the details. If a homeowner pays a utility bill online—another few API calls go to work behind the scenes to complete the transaction. If that homeowner then charts directions using a mapping service or orders a car through a ridesharing service, still more API calls are involved. </span></p>
<h2><span style="font-weight: 400;">A large portion of API traffic can currently be attributed to some kind of human action and follows a request-response model.</span></h2>
<p><span style="font-weight: 400;">What this means is that a person does something that triggers an API call in the first place. API traffic driven by machines instead of humans, in contrast, follows different, programmatic patterns and, to date, has </span><a href="https://threatpost.com/automated-bots-growing-tool-for-hackers/131230/"><span style="font-weight: 400;">often involved malicious activities</span></a><span style="font-weight: 400;">, such as bots or attempts to breach security. </span></p>
<p><span style="font-weight: 400;">On Google Cloud’s Apigee team, however, we’ve observed that the API world is experiencing a shift, with benign programmatic API calls generated by algorithms or machine intelligence taking on more prominent roles in digital ecosystems and experiences. This shift is driven by several trends that open new dimensions for how enterprises leverage APIs and expand existing ones.</span></p>
<h3><strong>The rise of voice applications.</strong></h3>
<p><span style="font-weight: 400;">Though adoption estimates for voice technologies vary, it’s clear that </span><a href="https://www.techspot.com/news/78036-smart-speaker-adoption-nearly-doubled-over-last-year.html"><span style="font-weight: 400;">tens of millions of people in the U.S. alone</span></a><span style="font-weight: 400;"> regularly use smart speakers and voice-controlled digital assistants. It’s also clear that today’s users are </span><a href="https://techcrunch.com/2018/03/07/47-3-million-u-s-adults-have-access-to-a-smart-speaker-report-says/"><span style="font-weight: 400;">adopting voice much faster</span></a><span style="font-weight: 400;"> than past users adopted disruptive technologies such as television or the Internet. </span></p>
<p><span style="font-weight: 400;">With applications expanding rapidly </span><a href="https://venturebeat.com/2017/10/29/voice-interfaces-will-revolutionize-patient-engagement/"><span style="font-weight: 400;">into new areas such as healthcare</span></a><span style="font-weight: 400;"> and new use cases </span><a href="https://www.informationweek.com/strategic-cio/it-strategy/voice-assistants-coming-to-the-enterprise/d/d-id/1333642"><span style="font-weight: 400;">emerging in the enterprise</span></a><span style="font-weight: 400;">, voice technologies are poised to grow far beyond their origins on smartphones and smart speakers. There are now even applications that let users </span><a href="https://techcrunch.com/2019/01/07/kohler-put-alexa-in-a-toilet-so-happy-new-year/"><span style="font-weight: 400;">raise a toilet seat</span></a><span style="font-weight: 400;"> using only their voice!</span></p>
<p><span style="font-weight: 400;">Voice technologies are complicated and potentially expensive to develop, which is one reason that so many companies have made their natural language processing technologies </span><a href="https://medium.com/@amit.bezalel/state-of-the-market-voice-dictation-apis-2f7d09c346d5"><span style="font-weight: 400;">available to others via APIs</span></a><span style="font-weight: 400;">. If a voice assistant hears a user say, “Pay my utility bill,” the assistant needs to understand the unstated nuances of the instruction: “Pay my utility bill from PG&amp;E for the current month using my stored credit card.” </span></p>
<p><span style="font-weight: 400;">This sort of task relies heavily on machine learning, with the user’s simple request into the voice system resulting in potentially hundreds of API calls across the backend, all driven by machine intelligence figuring things out. As more use cases integrate voice, the underlying machine learning technologies—and the APIs that make those technologies leverageable—will continue to grow in prominence.  </span></p>
<h3><strong>The expansion of IoT and home automation.</strong></h3>
<p><span style="font-weight: 400;">At the recent CES conference, </span><a href="https://www.thestreet.com/opinion/ces-takeaway-the-internet-of-things-is-mushrooming-14832126"><span style="font-weight: 400;">enthusiasm for the Internet of Things</span></a><span style="font-weight: 400;"> (IoT) </span><a href="https://www.techradar.com/news/best-smart-home-tech-of-ces-2019-the-coolest-iot-gadgets-we-saw-in-las-vegas"><span style="font-weight: 400;">continued to grow</span></a><span style="font-weight: 400;">, with connected, communicating devices filling booth after booth and keynote after keynote across Las Vegas. Many analysts estimate there are already </span><a href="https://iot-analytics.com/state-of-the-iot-update-q1-q2-2018-number-of-iot-devices-now-7b/"><span style="font-weight: 400;">more connected devices</span></a><span style="font-weight: 400;"> in use than </span><a href="https://www.zdnet.com/article/iot-devices-will-outnumber-the-worlds-population-this-year-for-the-first-time/"><span style="font-weight: 400;">people on the planet</span></a><span style="font-weight: 400;">—and the deluge of sensing, communicating, intelligent devices is not stopping.  </span></p>
<p><span style="font-weight: 400;">IoT devices integrate with each other and with voice assistants through APIs &#8212; and through recipes from organizations such as </span><a href="https://ifttt.com/blog/2016/06/the-internet-of-things-on-ifttt"><span style="font-weight: 400;">IFTTT</span></a><span style="font-weight: 400;">. With hundreds of thousands of different types of devices, bespoke integrations just do not work. Though APIs cannot solve all challenges associated with more profound business logic, they can simplify the mixing and matching, making it easier for all the devices and services to interact with one another. </span></p>
<h2><strong>APIs take artificial intelligence mainstream.</strong></h2>
<p><span style="font-weight: 400;">Artificial intelligence (AI) is arguably most useful when it can be leveraged into applications. However, as alluded in the above point about developing voice technologies, not every team or enterprise has the capability to do AI from scratch. </span></p>
<p><span style="font-weight: 400;">Consequently, we expect to see API-driven AI in which one team, or one business builds an excellent model in some domain, and other firms or teams </span><a href="https://www.cio.com/article/3204151/artificial-intelligence/apis-ecosystems-and-the-democratization-of-machine-intelligence.html"><span style="font-weight: 400;">leverage that work through APIs</span></a><span style="font-weight: 400;">. These teams or businesses may then develop their own AI models, which, in turn, another team might leverage. We already see examples of this, such as Google’s AutoML for </span><a href="https://techcrunch.com/2018/07/24/google-brings-support-for-custom-translations-and-text-categorization-to-automl/"><span style="font-weight: 400;">image and text analysis</span></a><span style="font-weight: 400;">.</span></p>
<h2><span style="font-weight: 400;">Bot attacks continue to rise</span></h2>
<p><span style="font-weight: 400;">Though most of the previous trends involve machine-triggered APIs being used for beneficial or neutral purposes, bot attacks and similar malign uses cases are still growing too. Attackers </span><a href="https://www.zdnet.com/article/this-botnet-snares-your-smart-devices-to-perform-ddos-attacks/"><span style="font-weight: 400;">continue to use botnets</span></a><span style="font-weight: 400;"> to take down sites and apps with distributed denial of service campaigns. </span><a href="https://www.cryptovibes.com/knowledge/crypto-trading-bots-what-they-are-and-the-risks-associated-with-them/"><span style="font-weight: 400;">Crypto-miners</span></a><span style="font-weight: 400;"> have begun leveraging API vulnerabilities to </span><a href="https://thenewstack.io/critical-vulnerability-allows-kubernetes-node-hacking/"><span style="font-weight: 400;">take over container orchestration platforms</span></a><span style="font-weight: 400;"> and steal enterprises’ compute power. Other bad actors are using bots to </span><a href="https://www.theregister.co.uk/2018/09/24/akamai_state_of_the_internet_report/"><span style="font-weight: 400;">steal credentials</span></a><span style="font-weight: 400;">. </span></p>
<p><span style="font-weight: 400;">We anticipate APIs will continue to bear much of the burden of nefarious machine-driven traffic. The traffic could potentially saturate backends unless the right security is built into the APIs. Indeed, in the December 2017 report “</span><a href="https://www.gartner.com/doc/3834704/build-effective-api-security-strategy"><span style="font-weight: 400;">How to Build an Effective API Security Strategy</span></a><span style="font-weight: 400;">,” Gartner analysts Mark O’Neill, Dionisio Zumerle, and Jeremy D’Hoinne predict that “[b]y 2022, API abuses will be the most-frequent attack vector resulting in data breaches for enterprise web applications.” </span></p>
<p><span style="font-weight: 400;">The rise of machine-driven API traffic among bad actors is precipitating a rise in machine-driven API traffic from enterprises working to ward off attackers. Organizations need robust security protections at the API level that include not only standards such as authentication and encryption but also smart algorithms and machine learning that can </span><a href="https://www.rtinsights.com/with-apis-dealing-with-bad-bots-is-the-cost-of-success/"><span style="font-weight: 400;">recognize bad actors and take steps to stop them</span></a><span style="font-weight: 400;">. </span></p>
<h3><strong>Embrace the machines.</strong></h3>
<p><span style="font-weight: 400;">We should acknowledge and embrace the fact that “robots” are our new partners in the API world. Machine-driven API calls will likely help us to interact with devices and services in new ways, inject dumb devices with new use cases and intelligence.</span></p>
<p><span style="font-weight: 400;">These actions by humans, calling to and from API&#8217;s will make AI accessible to more organizations and developers, and spot crooks that would have otherwise evaded human detection. The path forward will include pitfalls and obstacles, but with smarter machines and smarter humans working together, the future is bright.</span></p>
<div class="clearfix"></div>
<div class="menu-social-media-container" id="single-post-share-mobile">
<ul id="menu-social-media" class="menu">
<li> <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F" target="_blank" title="Facebook"><img src="https://readwrite.com/wp-content/themes/rw/images/fb-icon-light.png" /></a></li>
<li><a href="https://twitter.com/intent/tweet?text=How%20APIs%20and%20Machine%20Learning%20are%20Evolving&amp;url=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F&amp;via=Wptheme" title="Twitter" target="_blank"><img src="https://readwrite.com/wp-content/themes/rw/images/twitter-icon-light.png" /></a></li>
<li><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F" title="Linkedin" target="_blank"><img src="https://readwrite.com/wp-content/themes/rw/images/insta-icon-light.png" /></a></li>
<li><a href="mailto:?Subject=Post From Read Write&Body=I%20saw%20this%20and%20thought%20of%20you!%20https%3A%2F%2Freadwrite.com%2F2019%2F03%2F21%2Fhow-apis-and-machine-learning-are-evolving%2F&text=How%20APIs%20and%20Machine%20Learning%20are%20Evolving" title="Email" target="_blank"><img src="https://readwrite.com/wp-content/themes/rw/images/email-share-icon.png" /></a></li>
</ul>
</div>
<div class="clearfix"></div>
<div class="row popular-tags">
<div class="col-md-12">
<span class="tag-label">Tags:</span>
<ul class="post_tags"><li><a href='https://readwrite.com/tag/ai-machine-learning' title='AI Machine Learning Tag' class='ai-machine-learning'>#AI Machine Learning</a></li><li><a href='https://readwrite.com/tag/apis' title='APIs Tag' class='apis'>#APIs</a></li><li><a href='https://readwrite.com/tag/auto-home' title='auto-home Tag' class='auto-home'>#auto-home</a></li><li><a href='https://readwrite.com/tag/connected-devices' title='Connected Devices Tag' class='connected-devices'>#Connected Devices</a></li><li><a href='https://readwrite.com/tag/iot' title='IoT Tag' class='iot'>#IoT</a></li></ul> </div>
</div>
<div class="clearfix"></div>
<div class="about-author">
<div class="author-info">
<div class="author-avatar col-md-2">
<img alt='' src='https://secure.gravatar.com/avatar/5fed529fbed34bb80eaa09e6af7f81d0?s=125&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/5fed529fbed34bb80eaa09e6af7f81d0?s=250&#038;d=mm&#038;r=g 2x' class='avatar avatar-125 photo' height='125' width='125' /> </div>
<div class="author-description col-md-10">
<h3 class="author-title"><a href="https://readwrite.com/author/anant-jhingran/">Anant Jhingran</a></h3>
<h5 class="author-role">
</h5>
<p class="author-bio">
 Anant Jhingran serves as CTO and leads the product strategy &amp; development at Apigee. </p>
<div class="menu-social-media-container">
<ul id="menu-social-media" class="menu">
</ul>
</div>
</div>
</div>
</div>
<div class="clearfix"></div>
<div class="related_posts col-md-12">
<div id="related_posts" class="col-md-12"><h3>Related Posts</h3><ul> <li class="col-md-3">
<div class="relatedthumb">
<a href="https://readwrite.com/2019/03/20/debunking-ai-myths-the-importance-of-creativity-in-ai/" rel="bookmark" title="Debunking AI Myths: The Importance of Creativity in AI">
<img width="182" height="125" src="https://images.readwrite.com/wp-content/uploads/2019/03/Screen-Shot-2019-03-08-at-9.03.32-AM-182x125.png" class="attachment-related-post size-related-post wp-post-image" alt="AI and human creativity are greater than the sum of their parts" /> </a>
</div>
<div class="relatedcontent">
<h6><a href="https://readwrite.com/2019/03/20/debunking-ai-myths-the-importance-of-creativity-in-ai/" rel="bookmark" title="Debunking AI Myths: The Importance of Creativity in AI">Debunking AI Myths: The Importance of Creativit...</a></h6>
</div>
</li>
<li class="col-md-3">
<div class="relatedthumb">
<a href="https://readwrite.com/2019/03/18/5-ways-artificial-intelligence-is-transforming-recruitment-in-2019/" rel="bookmark" title="5 Ways Artificial Intelligence is Transforming Recruitment in 2019">
<img width="182" height="125" src="https://images.readwrite.com/wp-content/uploads/2019/02/accomplishment-agreement-business-1249158-182x125.jpg" class="attachment-related-post size-related-post wp-post-image" alt="" /> </a>
</div>
<div class="relatedcontent">
<h6><a href="https://readwrite.com/2019/03/18/5-ways-artificial-intelligence-is-transforming-recruitment-in-2019/" rel="bookmark" title="5 Ways Artificial Intelligence is Transforming Recruitment in 2019">5 Ways Artificial Intelligence is Transforming ...</a></h6>
</div>
</li>
<li class="col-md-3">
<div class="relatedthumb">
<a href="https://readwrite.com/2019/03/08/ways-enhanced-technology-has-changed-the-nature-of-business/" rel="bookmark" title="Ways Enhanced Technology has Changed the Nature of Business">
<img width="182" height="125" src="https://images.readwrite.com/wp-content/uploads/2019/02/Ways-Enhanced-Technology-has-Changed-the-Nature-of-Business-182x125.jpg" class="attachment-related-post size-related-post wp-post-image" alt="tech has changed the nature of business" /> </a>
</div>
<div class="relatedcontent">
<h6><a href="https://readwrite.com/2019/03/08/ways-enhanced-technology-has-changed-the-nature-of-business/" rel="bookmark" title="Ways Enhanced Technology has Changed the Nature of Business">Ways Enhanced Technology has Changed the Nature...</a></h6>
</div>
</li>
<li class="col-md-3">
<div class="relatedthumb">
<a href="https://readwrite.com/2019/03/07/heres-why-ai-is-the-solution-to-ecommerce-businesss-biggest-woes/" rel="bookmark" title="Here’s Why AI is the Solution to eCommerce Business’s Biggest Woes">
<img width="182" height="125" src="https://images.readwrite.com/wp-content/uploads/2019/02/Here%E2%80%99s-Why-AI-is-the-Solution-to-E-Commerce-Business%E2%80%99s-Biggest-Woes-182x125.jpg" class="attachment-related-post size-related-post wp-post-image" alt="Here’s Why AI is the Solution to E-Commerce Business’s Biggest Woes" /> </a>
</div>
<div class="relatedcontent">
<h6><a href="https://readwrite.com/2019/03/07/heres-why-ai-is-the-solution-to-ecommerce-businesss-biggest-woes/" rel="bookmark" title="Here’s Why AI is the Solution to eCommerce Business’s Biggest Woes">Here’s Why AI is the Solution to eCommerce Busi...</a></h6>
</div>
</li>
</ul></div> </div>
</div>
</div>
</div>
</article>
</main>
</div>
</div>
<footer id="colophon" class="site-footer col-md-10 offset-2" role="contentinfo">
<div class="site-info">
<div class="site-branding">
<a href="https://readwrite.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="148" height="26" src="https://images.readwrite.com/wp-content/uploads/2018/05/logo.png" class="custom-logo" alt="ReadWrite" itemprop="logo" /></a> </div>
</div>
<div class="row footer-nav-links">
<div class="col-md-8 foot-nav">
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-foot-menu-container"><ul id="menu-foot-menu" class="nav-menu"><li id="menu-item-125079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125079"><a href="https://readwrite.com/about/">About</a></li>
<li id="menu-item-125080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125080"><a href="https://readwrite.com/advertise/">Advertise</a></li>
<li id="menu-item-125081" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125081"><a href="https://readwrite.com/contact/">Contact</a></li>
<li id="menu-item-125082" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125082"><a href="https://readwrite.com/events/">Events</a></li>
<li id="menu-item-125083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125083"><a href="https://readwrite.com/privacy/">Privacy</a></li>
<li id="menu-item-125638" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-125638"><a href="/contributor-guidelines/">Guest Post</a></li>
<li id="menu-item-125084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125084"><a href="https://readwrite.com/subscribe/">Subscribe</a></li>
</ul></div> </nav>
</div>
<div class="col-md-4 foot-nav email-subscription">
</div>
</div>
<div class="row footer-links">
<div class="col-md-6 site-terms">
<div class="menu-site-terms-container"><ul id="menu-site-terms" class="terms-nav"><li id="menu-item-125056" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125056"><a href="https://readwrite.com/privacy/">Privacy</a></li>
</ul></div>
<div class="copyright"></div>
</div>
<div class="col-md-6 footer-social-nav">
<nav id="footer-social-navigation" class="social-navigation" role="navigation">
<div class="menu-footer-social-menu-container"><ul id="menu-footer-social-menu" class="menu"><li id="menu-item-125059" class="fb menu-item menu-item-type-custom menu-item-object-custom menu-item-125059"><a target="_blank" href="https://www.facebook.com/ReadWrite"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-125060" class="twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-125060"><a target="_blank" href="https://twitter.com/RWW"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-125061" class="insta menu-item menu-item-type-custom menu-item-object-custom menu-item-125061"><a target="_blank" href="https://www.instagram.com/readwritedotcom/"><span class="screen-reader-text">Instagram</span></a></li>
<li id="menu-item-125065" class="gplus menu-item menu-item-type-custom menu-item-object-custom menu-item-125065"><a target="_blank" href="https://plus.google.com/+ReadWriteWeb/posts"><span class="screen-reader-text">Gplus</span></a></li>
<li id="menu-item-125066" class="ytube menu-item menu-item-type-custom menu-item-object-custom menu-item-125066"><a target="_blank" href="https://www.youtube.com/channel/UClMPvTStrcn829w34OWNEPw"><span class="screen-reader-text">Youtube</span></a></li>
</ul></div> </nav>
</div>
</div>
</footer>
</div>
</div>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-421291-1', 'auto');
  ga('send', 'pageview');
  ga('set', 'anonymizeIp', true);
  </script>
<script>
		var advanced_ads_ga_UID = false;
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();</script><script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='a51dd0819147e3d3dc2e1729743f88213ae2b2990c36c1a5d4bea16c91682288';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script> <script type="application/javascript">
      var ajaxurl = "https://readwrite.com/wp-admin/admin-ajax.php";

      function sumo_add_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_add_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_remove_woocommerce_coupon(code) {
        jQuery.post(ajaxurl, {
          action: 'sumo_remove_woocommerce_coupon',
          code: code,
        });
      }

      function sumo_get_woocommerce_cart_subtotal(callback) {
        jQuery.ajax({
          method: 'POST',
          url: ajaxurl,
          dataType: 'html',
          data: {
            action: 'sumo_get_woocommerce_cart_subtotal',
          },
          success: function(subtotal) {
            return callback(null, subtotal);
          },
          error: function(err) {
            return callback(err, 0);
          }
        });
      }
    </script>
<link rel='stylesheet' id='typekit-lib-css' href='https://use.typekit.net/nzt0afb.css?ver=5.1.1' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/readwrite.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://readwrite.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/25/public/assets/js/497.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_sticky_settings = {"check_position_fixed":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/410/public/assets/js/782.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/readwrite.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track","method":"frontend","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://readwrite.com/wp-content/uploads/706/421/public/assets/js/165.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://readwrite.com/wp-content/themes/rw/scripts/bootstrap.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"<span class=\"screen-reader-text\">expand child menu<\/span>","collapse":"<span class=\"screen-reader-text\">collapse child menu<\/span>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://readwrite.com/wp-content/themes/rw/scripts/functions.js'></script>
<script>var advads_placement_tests = [];
var advads_passive_ads = {};
var advads_passive_groups = {};
var advads_passive_placements = {};
var advads_ajax_queries = [{"id":"home_header_728","method":"placement","params":{"previous_method":"placement","previous_id":"home_header_728","post":{"id":150315,"author":"24692","post_type":"post"},"wp_the_query":{"term_id":"","taxonomy":"","is_main_query":true,"page":1,"numpages":1,"is_archive":false,"is_search":false,"is_home":false,"is_404":false,"is_attachment":false,"is_singular":true,"is_front_page":false,"is_feed":false},"url_parameter":"\/2019\/03\/21\/how-apis-and-machine-learning-are-evolving\/","placement_type":"default","cache-busting":"auto","output":{"class":["rwads-home_header_728"],"placement_id":"home_header_728"},"global_output":true},"elementid":"rwads-12ceb54b5c42fbf516cc5e3fe5d911c0","blog_id":1}];
var advads_has_ads = [];
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( window.advanced_ads_pro ) {advanced_ads_pro.process_passive_cb();} else if ( window.console && window.console.log ) {console.log('Advanced Ads Pro: cache-busting can not be initialized');}});</script><script>        
        var wppbRecaptchaCallback = function() {
            if( typeof window.wppbRecaptchaCallbackExecuted == "undefined" ){//see if we executed this before
                jQuery(".wppb-recaptcha-element").each(function(){
                    recID = grecaptcha.render( jQuery(this).attr("id"), {
                        "sitekey" : "6LciKVwUAAAAABHLgNRMEwXRo-RIyShB6Da0LW6q",                        
                        "error-callback": wppbRecaptchaInitializationError,
                                                
                     });                 
                });
                window.wppbRecaptchaCallbackExecuted = true;//we use this to make sure we only run the callback once
            }
        };
        
        /* the callback function for when the captcha does not load propperly, maybe network problem or wrong keys  */
        function wppbRecaptchaInitializationError(){            
            window.wppbRecaptchaInitError = true;
            //add a captcha field so we do not just let the form submit if we do not have a captcha response
            jQuery( ".wppb-recaptcha-element" ).after('<input type="hidden" id="wppb_recaptcha_load_error" name="wppb_recaptcha_load_error" value="5ac2dad6ab" />');
        }
        
        /* compatibility with other plugins that may include recaptcha with an onload callback. if their script loads first then our callback will not execute so call it explicitly  */        
        jQuery( window ).on( "load", function() {
            wppbRecaptchaCallback();
        });
    </script><script src="https://www.google.com/recaptcha/api.js?onload=wppbRecaptchaCallback&render=explicit" async defer></script><script type="text/javascript">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</script>
</body>
</html>
