Apple has all but announced it will no longer support Mac computers running Snow Leopard, or OS X 10.6. 

On Tuesday, the company released an important update for Mavericks, or OS X 10.9, plus security updates for its two predecessors, Mountain Lion (10.8) and Lion (10.7), but there was nothing for Snow Leopard or any other previously-released versions of OS X. All of the updates included a critical patch that resolved a major security exploit.

Snow Leopard hasn't been issued an update since September 2013, which has led many to believe that the four-year-old operating system is being retired. Apple might be distancing itself from Microsoft’s tradition of supporting older operating systems for decades and beyond, a practice some call excessive. Microsoft’s Windows XP came out on October 25, 2001—more than 12 years ago—but Microsoft says it will continue supporting the system until April 8, 2014

Meanwhile, Snow Leopard has been around for just 4 years—since August 28, 2009—which explains why one in five Macs are still operating on that version of OS X. 

See also: Apple Celebrates 30 Years Of The Mac Computer

Perhaps Apple’s thinking is that there’s no reason for Snow Leopard users not to upgrade to OS X Mavericks, given that it’s now possible to upgrade directly from Snow Leopard to its latest OS—for free. Unlike previous $20 upgrades like Lion and Mountain Lion, Mavericks doesn’t cost a thing. 

Apple might have also retired Snow Leopard since it's the last remaining operating system that supports 32-bit Macs, which contain first generation “Core” processors. Mac OS X 10.7 Lion, and all versions that followed, are 64-bit. (Apple's newest iOS devices are also 64-bit.) 

It’s not the first time Apple has abandoned older machines after a major tech transition—ask anyone who has tried to upgrade the software on the older Mac Mini with a PowerPC processor. If you don't own a 64-bit Mac, it’s now impossible to get upgrades. 

But the worst part? When Apple drops a platform, so does everyone else. Now it won’t be long until later versions of Chrome and Firefox no longer mesh with Snow Leopard. It's just a shame how Apple customers are penalized if they haven't purchased new Mac hardware since 2009.

Updated at 3:15pm PT on February 28 to clarify OS X Snow Leopard has not been officially retired, and removed the question about whether or not the recent OS X exploit exists in Snow Leopard (some ReadWrite commenters contend that it doesn't).

Photo courtesy of Apple