Topic navigation is up and running on Read/Write Web, including cross-posting to both K-Collector and Topic Exchange. You'll notice on the main menu, it now lists internal topics (or categories if you prefer - you say tom-ah-to, I say tom-ay-to). And in my RSS file, I've added references to both KC and TE. Here's basically what I added in the MT template:

<ent:cloud ent:href="http://topicexchange.com/topics">
<ent:topic ent:id="<$MTEntryCategory dirify="1"$>" ent:href="http://topicexchange.com/t/<$MTEntryCategory dirify="1"$>/"><$MTEntryCategory dirify="1"$></ent:topic>
</ent:cloud>
<ent:cloud ent:href="http://w4.evectors.it/itEntDirectory/topicRoll.opml">
<ent:topic ent:classification="what" ent:href="http://w4.evectors.it/itEntDirectory/topic?topic= <$MTEntryCategory dirify="1"$>" ent:id="<$MTEntryCategory dirify="1"$>"><$MTEntryCategory$></ent:topic>
</ent:cloud>

The KC and TE references are pretty similar, except that KC doesn't need the dirify="1" bit for the topic name. Dirify in this context just means the topic value is made lower-case and if it's a double word an underscore is added between the two words.

Each post references R/WW, KC & TC

At the end of each individual post, you'll now notice there are 3 links: the first one takes you to the Read/Write Web archive for the topic I've specified for the post. The next two links take you to the respective KC and TE pages for that topic. This is all done automatically using the <MTCategory> tag (oh, did I mention I'm using Category now instead of Keyword?).

There is one downside: sometimes TE and KC won't have the same topic name as me. In the case of this post here, I'm using the topic name "Movable Type" - which is fine because both TE and KC have a topic by that name. But a lot of times the topics don't synch. But that's a whole other issue, which I can't fix by myself.

So that's me done with topics for a little while. I'm going to relax a bit this week and write up some laid-back R/WW posts.